NewDay Credit Cards - Available This Month

Our next release includes an import upgrade for HSBC customers (see separate post).

Once that’s in place, a few days later we will be able to switch on our next provider: NewDay credit cards.

This includes the following brands:

  • Amazon Credit Card
  • Aqua Credit Card
  • Marbles Credit Card
  • Opus Credit Card
  • Fluid Credit Card
  • TUI Credit Card
  • Debenhams Credit Card
  • House of Fraser Credit Card
  • Laura Ashley Credit Card
  • Burton Credit Card
  • Dorothy Perkins Credit Card
  • Miss Selfridge Credit Card
  • Outfit Credit Card
  • Topman Credit Card
  • Wallis Credit Card
  • Argos Credit Card
  • Evans Credit Card

We plan to switch all of these on before the end of the month. We will contact all customers as soon as they are available.



Hi all - the above brands are all available in our app now.

However, NewDay have a problem with their IOS app which we’ve raised lots of times but we’ve yet to hear back on when they will fix this. We’ve been chasing them for multiple days, but nothing back yet :slightly_frowning_face:

It seems that if you have their app installed they always try to use tha tot complete the account connection. Sadly this is not working and you are presenting with a blank screen at the end of this process. For example, this is the Amazon card:

So for now, we’ve switched on the products with guidance for IOS users that in order to connect, you need to temporarily remove the NewDay app from your device. With that not present, you will be taken to their Online Banking service to complete the connection (which works!).

Once connected to Snoop, you can re-install their app.

Sorry this isn’t ideal. We hope NewDay fix this as quickly as possible.



Hi Paul,

Thanks for adding the NewDay cards - that was the final account I was waiting to add to Snoop! Just to let you know I could not get my account to connect using the Aqua app, it kept giving me an error message, but when I uninstalled the app and did it through the browser it connected OK. I’m using Android 10.

Edit: I’m not sure whether it has successfully connected, the logo is greyed out and I can’t click on it - not sure if it’s still pending/importing?

Thanks for letting me know @Joe we were under the impression that this was just impacting IOS users and we’ve had other Android users correct even though they have the app installed.

However, your experience may suggest it’s a wider issue so we will probably need to change our guidance for Android users too.

Now, if we could only get NewDay to respond to any questions… :blush: !

Oh @Joe I’ve just seen your Edit… that doesn’t sound good I’m afraid. I will investigate further as it should only be in that position for a couple of minutes at best.

I’ll come back to you via email.

Thanks, Paul! - I tried again to see if it had worked so I now have two Aqua Credit Cards showing on my account. One of them has just turned to Error and the other is still greyed out. I had a look in the manage account sections it’s showing as -1 days left.

Thanks for your help looking into this.

Hi everyone - I’m afraid we are not off to a good start with NewDay.

All connection attempts are now failing and we’ve still not been able to reach anyone at NewDay for support. We have investigated and can now see that something stopped working there yesterday afternoon (before that connections were successful).

There is a central Open Banking system for raising issues and NewDay also publish contact details on their own developer portal (, however we’ve received no responses on any of those channels yet. The telephone number published just takes us through to their internal IT service desk who were not able to help at all :slightly_frowning_face:

We will continue to chase and update whenever we know more.


Hi @paul_k,

Just to say, there is a workaround for the app issue where you don’t have to fully remove the app. You can just go to iOS settings, go to storage, search for the relevant app and select to “Offload App”.

This uninstalls the app but keeps it registered on your device (so it is easier to reinstall).

After connecting successfully, simply press on the app and it will re-download from the App Store. Once re-installed, then open the app and you get straight back in without having to set it up again.

That’s a great suggestion @Seb so thanks for sharing that.

Just to update everyone - I’m afraid we’ve still had zero response from NewDay on any available channel to us. We will keep pushing for answers today on the app problem and the bigger issue impacting us since then.

Just getting some contact with someone will be a good first step :wink: !



Thanks for the update Paul!

It seems that NewDay aren’t the most responsive - it’s not just you, but also the team at Emma have said publicly that they have been unable to reach them.

Hopefully it’s sorted soon.

1 Like

Thanks @Seb yes I’ve noticed several other Open Banking apps are having the same problem as us in reaching them for any type of support. In some ways that is reassuring that it’s not just us, but I’d certainly rather none of us were having this issue (for the good of Open Banking!).

Regardless of the problem with the app journey, based on what we are seeing I suspect their APIs are not working at all right now for any 3rd party - we think they broke on Thursday afternoon from what we can see. We did have accounts connecting and refreshing before that time.

Either way, we did finally get an email back from them yesterday to say they are investigating, so a small step forward.

I will update you as soon as we know more.

1 Like

Hi everyone - we’ve not heard back from NewDay today (anyone spot a theme? :blush:)

However, we have a few customers who have successfully connected their accounts this afternoon. We can’t be sure if this is a temporary improvement or if they have fix whatever problem they obviously have had in the last few days.

Also - to confirm their mobile app will NOT work as part of the connection process. The connection only works when using a mobile browser. So IOS users will need to remove/offload their app temporarily. Android users will hopefully get a prompt to open the browser rather than their credit card app. We assume they are also fixing this one as it’s been a known problem for multiple weeks now.



Just to say I tried to add a NewDay Amazon premium card today and despite all the tips about offloading and uninstalling the card app failed to add the card to snoop.
It looked like it went through ok and on the snoop home page showed ‘downloading transactions’ but then failed with the option to try again or remove

Hi Ian - I’ve sent you an email to update you.

Sadly you are one of a small number of customers who NewDay are returning errors for. We wish we knew why this was or what could be done about it.

We also wish they replied to support requests they get sent. We’ve had requests about errors outstanding for at least 3 weeks - and the one about their mobile apps not working can now be measured in months :frowning:

We are not alone in this - visiting forums of other Open Banking apps and you will see similar stories of frustration.

I will come back to you as soon as I hear anything back from them.