Amex not refreshing

Hi, I’m having an issue where my American Express account hasn’t refreshed in the last 4 days, even though I’ve reconnected and tried to force refresh - anyone else having the same issue?

Hi @PictoUK - we wrote to all Amex customers on Monday so apologies if you didn’t receive this for some reason.

Basically Amex had an issue over the weekend which broke the majority of connections. It didn’t just impact Snoop.

They are still investigating, but we did write to people with the following work-around:

  • Leave the account as is
  • Tap on the + icon as if you are adding a new account
  • Select Amex again and complete the connection process in their app
  • Return to Snoop and wait 1-2 mins for the account to refresh

That will hopefully create a fresh connection at Amex and should mean your card refreshes again.


1 Like

I have the same issue

The fix that I posted above was working until yesterday (and we wrote to everyone about this last week and had messages showing in app).

However, I’m afraid that Amex appear to have made a further change yesterday which was breaking all connections again.

We’ve made no changes at our end on this and no other banks are impacted so we are very confident Amex changed something yesterday without telling us. So we’ve again asked them for an urgent investigation and fix.

Sorry for the inconvenience - it’s extremely frustrating for us as well.


Hi everyone - just to update you about the regular conversations with Amex. We will be sending an email to everyone with a connected Amex card later this evening.

There are two separate problems that have happened in the last two weeks:

  1. In mid October, Amex incorrectly stopped connections on a very high number of accounts. Those impacted were people who had cards connected for a long time in Snoop and have used the ‘reconnect’ option at least once.

  2. On Tuesday 31st October, Amex then deployed an entirely separate system change which has broken some of their third party connections, including Snoop.

Amex have acknowledged both of these issues and they are working on a resolution as quickly as possible. However I’m afraid it’s not possible for us to estimate how quickly their service will be returned. We will be speaking to them regularly until it’s resolved.

As you can imagine, we are very frustrated about this and we will be discussing this further with both Amex and the regulator who oversees Open Banking in the UK. However, right now our focus is to get the service back up and running as quickly as possible.



Hi everyone - we are extremely frustrated that this issue is still ongoing. We’ve been told the fix should be implemented by Amex tomorrow afternoon:

This has been raised as a P1 on our end and are working towards a fix asap and plan for a production deployment if everything goes to plan by tomorrow.

I will update further once we’ve seen this in place or if we have any further news.


I’m unable to link my Amex account. I just see:

Your bank is temporarily unavailable

Please try again later.

Any update from Amex?

Hi @T3ster - yes Amex is still unavailable. However…

@freddyq Amex have made some fixes this afternoon as promised. We are hoping their service will be fully available to us before midnight and before our scheduled overnight refresh is due to start.

As soon as we can see it working, we will remove the message you currently see in app and I’ll post a further update here.


Ok thanks for the update. For what it’s worth, I’m not seeing any message in the app about Amex being unavailable. It just isn’t bringing any new transactions in since the issue started. But I’ll wait to hear an update tomorrow.

When you tap on the Amex account you should see this full screen message @freddyq

Good news - Amex has been restored in the early hours of this morning.

The majority of accounts should have refreshed automatically. If for any reason your account is still not updating, the fix is:

  • Leave the account as is
  • Tap on the + icon from the homepage to add a new account
  • Select Amex again
  • Complete the connection process again and return to Snoop
  • Wait 1-2 minutes for the account to refresh

This should force a fresh connection with Amex.

I’ve tried this, and every time I refresh I seem to be losing transactions from the app. I’m now not seeing anything since August. I really hope I’ve not lost all my previous categorisations. I thought these transactions would be saved within the app?

Hi @toffah - I can’t think of any reason why this happened. We never touch any transactions older than 10 days in a refresh or any other process… unless you actually delete an account in Snoop. As mentioned above there is no need to remove any account due to this problem.

Can you drop us a line at so we can investigate what’s happening for you?


EDIT at 07:55 - I’ve since realised the words in bold above are not accurate. We do review older transactions when someone uses the ‘add a new account’ experience. However, this should only be to check the bank hasn’t chnaged anything rather than re-importing everything. Updated for clarity.

I have sent the email as requested.

Ah, I’ve just refreshed another time and they are finally returning. Categorisation seem to have been lost though…

Thank you very much for flagging this @toffah. As per my email to you there is something strange going on here that could impact when you are using the ‘add account’ button to force a new connection with the bank.

I’ve updated my original post for clarity above.

The only thing we do in this situation for ‘old’ transactions is check nothing has changed with the bank. For us to have re-imported the historic transaction suggests something has changed since we first had the transactions. We are investigating now (and continuing to swear about Amex under our breath!)


I can confirm all my Amex transactions since the issue are showing in Snoop and historical transactions seem to be unaffected and still correctly categorised.

I didn’t need to force a refresh or attempt to add the Amex account again. Fingers crossed no more issues :crossed_fingers:

1 Like

Just want to publicly thank you and your engineering team for sorting the issue with my corrupted data. Communication throughout the whole process was also top-notch. Thank you.


Thanks very much @toffah for the kind words.

Sorry you were impacted even more than others with this incident. To explain to anyone curious, there was a particular time on the 31st October (after Amex had completed a release but before we knew about it!) where some data could have been negatively impacted. @toffah was one such unlucky customer.

The ‘add account’ experience that I talk about above would not normally cause the issue experience.

Hopefully Amex issues are behind us now - although we continue to discuss with them exactly what happened in the last month with a couple of problems they caused us and their customers.