Beta bugs

I’ve just downloaded the beta version of the app, and have started to add some of my accounts (the ones available). Here are my first observations and a bug or two:

  1. when I added my Monzo account, the Open Banking API (I assume?) instantly displayed my Monzo account details for me to confirm. Whilst I know that Open Banking is clever, this was a bit scary! “How does Snoop know my bank details with only the limited info I’ve given them so far!” And then when I came to add my Nationwide account, it took me to the Nationwide login page which felt a bit ‘safer’ - like my account details were still mine to provide. Not a bug obviously but worth noting for user adoption perception and whilst open banking can still be quite new to some users.

  2. I have an HSBC mortgage account so thought I’d see if I could add HSBC personal. But (as expected) it couldn’t be done. Rather than take me back to the Snoop app though, it took me to an Openwrks.com web page saying ‘Oops, somethings gone wrong’. I had to navigate back to Snoop myself (which is an opportunity to lose a user to distraction on their phone!)

  3. When Snoop was adding an account (little rotating circle over the provider name on the home screen) I couldn’t add any more accounts. I had to wait until it had finished, and synced, before it would let me add another account. Too long! I wanted to keep adding accounts even whilst it thought about my other account in the background.

  4. my Nationwide credit card is displaying completely the wrong number! It shows the balance as the amount available (i.e. left on the card up to my credit limit) NOT the actual balance of my card. Problem!

  5. Monzo just displays my account balance and doesn’t include my Monzo ‘pots’. I treat these like saving accounts (as do many people) so need to be displayed too please.

Keep up the good work Snoop team!

1 Like

Also, the homescreen (on my Android device) has a black background at the top meaning I can’t see the words in dark colour font written on it. I think it says ‘Your Money’ but I can’t be sure…

1 Like

Hey Charlotte - thanks for that AMAZING feedback!

I’ll take them 1-by-1 where I can!

  1. Did you have to login to your Monzo account to confirm your consent to share your data with Snoop (before you saw your account details)? We don’t have any of your data until you have explicitly provided your consent within your bank’s experience. With Open Banking being so new we definitely want to create as secure a linking journey as possible and highlight the fact that initial account linking is between a customer and their bank, not snoop.

  2. This is a know issue with HSBC (they are returning the wrong error codes) - this journey should be much better soon.

  3. Great feedback - we are going to look into this! :slight_smile:

  4. This is a new one for us but we are investigating with Nationwide.

  5. Monzo pots work slightly differently to normal savings accounts but we’re looking into how we can get them into Snoop ASAP

  6. That doesn’t sound good, apologies. Is it possible for you to send a screenshot to Tom (tom@snoop.app) and we will investigate it today? (if you could provide your device type as well that would be amazing)

Thanks again for taking the time to send through your feedback, it’s incredibly helpful.

Ross

Thanks Ross!

  1. When adding Monzo, no, I got no option to confirm consent before it just displayed my Monzo account details on screen.

2), 3), 5) Thanks!

  1. and 6) I’ve sent screenshots for both of these to Tom.

Thanks!

New one: a Snoop has recommended an app, I clicked on ‘Get it on Google Play’ and was just faced with an error that said: “To view this content, install and set up a web browsing app”. Well I already have both a functioning browser and Google Play so I was expecting Snoop to take me straight there!

1 Like

Hey Charlotte - which Snoop was it?

Ross

It was the Groceries “Too Good to Go” Snoop. I’ve just tried it on another Snoop and that connected to the Google Play store just fine.

1 Like

Hi. Went back to app after using earlier. Greeted with s teens which suggest there’s a problem with my Snoop (screenshots). Better to automatically log me out so I return to the login page??


!

Hi Richard, thanks so much for letting us know. That definitely doesn’t look right!

We’ll take a take a look at your Snoop account to see what’s happening and will get back to you.

Cara

Hey Richard - thanks for the feedback and sorry for the bug…we’ve never seen anything like that before!!

While we look into it, can I ask if logging out / killing the app and logging back in fixes the issue? Obviously we’ll get to the bottom of it regardless but sometimes this helps with the BETA version.

Have a great weekend,

Ross

Yeah. Logged back in as normal.

Great!

Delighted you’re back up and running for the weekend.

Thanks again for the feedback,

Ross

1 Like

On this view (screenshot) when I swipe the bottom half right I get the pinned snoops, but on the second swipe it doesn’t display the Snoop categories. I can’t take a video grab of it but it looks like it should show the categories - instead it bounces back to the latest Snoops

Thanks Richard - that’s really useful feedback.

We’ll ask our devs to take a look :+1:. Appreciate you taking the time to let us know.

Hope you have a lovely weekend,

Cara

1 Like

Another similar one today when entering the app after using it earlier in the day

1 Like

Hi Richard,

Thanks for letting us know. We’re working on a solution to fix the problem you’ve experienced but for the time being a log-out / sign-in is the most effective way to get your snoops back.

Thanks again,

Ross

Hi Guys,

I’ve found a small bug when changing categories.

After clicking on my bank and selecting a transaction, I changed the category from General to Finances and as expected it changed after pressing ‘apply’ but when I went back to the statement list the category hadn’t changed and was showing as ‘General’

If I come out of my banks statement list and then return, basically refreshing the feed, then the category is showing correctly as Finances.

I’ve re-tried this a few times with other transactions and categories and it does the same thing every time.

Cheers

Hi Leighton,

Thanks for letting us know. I’ve personally not seen that before and can’t recreate on iPhone so it may be an Android specific bug.

We’ll get this raised for investigation.

Appreciated as ever :blush:
Cara

Agreed, I also get it on Android! You have to exit Snoop and go back in for the categories to updates after changing them, including the category totals.

2 Likes

Thanks for confirming @charlwillis
We’re taking a look and will let you and @Leighton know when it’s sorted.

Cara

2 Likes